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Abbreviations 

Term Meaning 

CPU Central processing unit 

CIG Cardiointervalogram 

ECG Electrocardiogramm  

IRSA (RSAI) Index of regulatory system activity 

LED Light emitting diode 

HRV Heart rate variability 

OS Operational system 

PC Personal computer 

USB Universal serial bus 
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1. Introduction 

VARICARD-KARDi software is intended for use in structure of 
KARDiVAR system. 

KARDiVAR system is a computer system for stress level evaluation by a 
heart rate variability analysis.  

KARDiVAR system provides the non-invasive screening of HRV, IRSA and 
stress level using only 6 standard ECG leads, i.e. 4 wires only from the patient's 
wrists and ankles in sitting position, also the patient can be fully clothed. 

KARDiVAR system provides the analyzing and creating of stress level 
evaluation by a heart rate variability analysis in the form of stress level indicator of 
type "Traffic light", where the stress level zones is displayed by colors, which are 
simple for interpretations. The system provides the analyzing and showing basic 
parameters of heart rate variability analysis and creating the conclusion and 
comments, which requires much less professional skills and training for better and 
faster interpretation. 

1.1 Restrictions 

�� The KARDiVAR system is intended for screening analysis of the ECG 
signals only for adults. It is not suitable for children up to the age of 18 years old. 
The system can be used for children and teenagers up to age 12-18 years old only for 
monitoring the tendencies in dispersive parameter changes. For children and 
teenagers the use of the system is determined by the doctor in each specific case. 

�� The KARDiVAR system does not diagnose! The system functions to 
define index of regulatory system activity by a heart rate variability analysis and 
inform about the presence of the deviations. The KARDiVAR system is not a 
substitute the other clinical methods of heart diagnostics; it gives the additional 
information about the heart rate variability 

�� The drug taking can influence on the accuracy of the index of regulatory 
system activity and forming the conclusion and comments. If the system is used 
during the drug treatment it is necessary to compare the current data with the data 
collected before the drug taking. 

 

See also “KARDiVAR-User's Guide”. 
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2. VARICARD-KARDi software installation 

2.1 Installation for Windows XP 

Insert a disk with “VARICARD-KARDi” software into CD/DVD drive. The 
window of automatic loading will appear on the screen (fig. 1). 

 

Fig. 1. 

First it is necessary to install the driver of electronic key HASP HL. For this 
purpose choose the corresponding item in the window of automatic loading. After 
successful installation of the driver, connect the electronic key to USB port. Then it 
is necessary to connect the device to USB port. The system will demand a way to the 
driver of KARDiVAR system, specify a folder “driver” on the installation disk. 

Further it is possible to start the installation of “VARICARD-KARDi” 
software and the program “OutDoc” (for print The “Passport of Health”). At start of 
the installation there will appear the window shown on fig. 2. Further follow the 
instructions of the installation program. 



VARICARD-KARDi software. User’s Manual 

7 

 

Fig. 2. 
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3. VARICARD-KARDi software operation 

3.1 Main window: “KARDiVAR Registry” 

3.1.1 The General data 

Start the program “KARDiVAR” (further “program”). For this purpose two 
times click on a shortcut “KARDiVAR” on the desktop Windows or choose 
consistently: “Start -> All programs -> KARDiVAR”. There will be a main window 
of KARDiVAR program on the screen: “KARDiVAR Registry” (fig. 3) (further “the 
main window”). 

 

Fig. 3. 

This window allows to work with card files, patients’ cards lists, to look 
through cardiosignal lists or examination lists, results of examinations, and also to 
deduce a window of the input of a new examination or allows to view the before 
entered one. 

The list in the central part of the window, called “Patients’ cards list” 
contains the patients’ list. At the first start of the program it is empty. Patients’ lists 
are united in card files for convenience. Along with the information on each patient, 
the cardiosignals for each patient and the results of his examinations are put down in 
a card file, if there are any. Thus, the card file contains also the information on 
patients and data on their examination (signals and results). The principles of 
operation with patients’ cards will be described below. 
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The list in the bottom part of a window contains two lists which are switched 
by means of two bookmarks: “Cardiosignals” and “Results”. Only one list is visible 
simultaneously. The list “Cardiosignals” contains data on the current patient’s 
examination: date and time of examination (a column “Date and time”), length of 
examination (a column “Length”), the number of channels (or signals) in 
examination (a column “Channels”) and examination comments (a column 
“Comment”). The list “Results” contains examination results of the patient: date and 
time of getting the results (a column “Date and time”), further the parameters of 
variability follow, each in separate column. 

It is possible to classify the lists in the main window on any column. For this 
purpose click with the mouse the necessary column in the necessary list. 

Buttons  and  are intended for work with patients’ 
cards. 

The button  deduces a dialog box “ECG input”. 

The button  is accessible if the list “Cardiosignals” is 
chosen in the bottom part of a window and the patient has examinations saved in a 
database. This button deduces a dialog box “ECG input”. 

The button  is accessible if the list “Results” is 
chosen in the bottom part of a window and the patient has examination results saved 
in a database. This button deduces a dialog box “Results”. 

The button  is accessible if the list “Results” is 
chosen in the bottom part of a window and the patient has examination results saved 
in a database. This button deduces a program “Dinakont”. That program is used to 
show and print graphs of dynamics of examination results for a current patient. 

3.1.2 Card files 

At the first start one card file is already created. It refers to “CardFile1” and 
it is empty, that is does not contain data on patients. The list of card files is the left 
central part of a window and is called “CardFile list”. 

It is possible to change a card file name. For this purpose choose with a 
mouse a line with the necessary card file in the list of card files and press the right 
button of the mouse. There will appear a contextual menu (fig. 4). The command 
“Rename…” deduces a dialog box where it is necessary to enter the new name for 
the card file chosen in the list. Enter the new name and press the button “OK”. 
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Fig. 4. 

The command “Add cardfile…” allows to create an empty card file. Here 
appears the similar window where it is necessary to enter the name of a created card 
file and press the button “OK”. Then it will appear in the list of card files and it will 
be possible to work it, that is to add there patients’ cards. 

The command “Delete” removes the card file chosen in the list with all 
patients’ cards, their examinations and results of examinations without an 
opportunity of regeneration. Be cautious with this command! 

3.1.3 Databases 

Card files, in turn, are united in a database. The database is a set of files 
combined in one folder Windows. The name of a database corresponds to the name 
of a folder. Thus, the structure of the information storage in the program is 
following: the database comprises one (or a few) cardfiles, each card file contains 
patients’ cards, their examinations and results of examinations. The card file can be 
empty and can not comprise patients’ cards - as in our case at the first start of the 
program or after creation of a new card file.   

The program can work with several databases. But only with one it is 
possible simultaneously. At the first start of the program as it was already spoken 
above, the database already exists and contains one card file - “CardFile1”. This 
database is placed by default in a folder: “C:\Program Files\RAMENA\Database\”. 
The information on the database opened at the moment is seen at the very bottom of 
the main window of the program, in the status line.  

The current database can be replaced. For this purpose choose item of the 
menu “Cardfile -> Open database…”. There will be a dialog box where it is 
necessary to choose a folder with another database. Click on a folder that you are 
interested in and press the button “OK”. If everything is all right, the program will 
open the chosen database and in the list of card files the list of card files of the 
chosen database will be displayed. If the program gave the message “Database is not 
found”, there is no database in the chosen folder (there are no necessary files the 
database consists of), or a database is of any other format which is not supported by 
the program. 

Also the program allows to choose a place for new databases through the 
menu “Cardfile -> Create database…”. In the appeared dialog box choose a place of 
a new database and create in this place the catalogue with its name. Press the button 
" Create " for  generating a new database in the chosen catalogue. 
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3.1.4 Patients’ cards 

At the first start of the program the list of patients’ cards is empty. It is 

necessary to create a patient’s card. Click with a mouse the button  in the 
main window of the program or choose in the menu “Cardfile -> New card…”. 
There will be a dialog box  “Patient’s card” (fig. 5). 

 

Fig. 5. 

The given window is intended for input or change of the information on the 
patient. 

In the top part of a window there is the button  which is intended for 
blocking the data changes in fields of this dialog box. If it is in the pressed position, 
then it is possible to change the data in a window, if in the pulled position, then it is 
impossible to change the data. You can switch its position yourself. As we create a 
new card, this button is already in the pressed position, that is the window is ready 
for data input about the new patient. 

The following button  is intended for recording of a card in a 
card file. As we haven’t changed the data in the fields of this window, this button is 
inaccessible.  

The button  closes a window of a patient’s card. If there were any 
changes in a card the program will warn about it. 



VARICARD-KARDi software. User’s Manual 

12 

The information on the patient in a card is divided into three groups: the 
general data, the address and the data on patient’s work. There is the button-

bookmark:  which corresponds to each group. The button 
“Main” is pressed by default and we can enter the general data on the patient into a 
card: 

�� The Field “ID” - number of a card in a card file (it is filled automatically, 
but can be changed manually); 

�� The Field “Date and Time” - date and time when a card was filled in (it is 
entered automatically, but can be changed manually); 

�� The Field “Gender” - the patient’s sex; 

�� The Field “Name” -  name, surname, patronymic of the patient; 

�� The Field “Born date ” - birthday of the patient (you can enter either date 

of  birth or just year of a birth of the patient - it is switched by the button � ); 

�� The Field “ Height (sm) ” - growth of the patient in centimeters; 

�� The Field “ Weight (kg) ” - weight of the patient in kgs; 

�� The Field “Comments” - the comment on the patient. 

We enter the necessary data into the fields, for example, as shown in fig. 6, 
and we pass to a bookmark “Address” (fig. 7). 
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Fig. 6. 

 

Fig. 7. 

Here are the fields where it is possible to enter data on a patient’s place of 
living. These fields are not obligatory for filling. 
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The next bookmark of a window of a patient’s card is “Work” (fig. 8). It is 
similar to a bookmark with the patient’s address, but here it is possible to enter data 
on a patient’s place of employment. These fields also are not obligatory for filling. 

 

Fig. 8. 

When you have entered all the necessary data into a patient’s card press the 

button  to write down a card in a card file. If there will be any errors 
during the saving process (for example, such a card number already exists in a card 
file or any field necessary for filling remains empty), the program will inform about 
it. In this case it is necessary to change (or fill in) necessary data and repeat an 
attempt of recording of a card in a card file. After the successful record, the card can 
be closed with the button “Close”. In the list of patients of the main window the new 
line will appear. 

To view a patient’s card or change the data on the patient, first choose the 
necessary line in the list of patients’ cards of the main window and press the button 

 or choose the menu “Cardfile -> Open card…”. There will be a 

window with a patient’s card. It will be in a mode of viewing (the button  will 
be pulled position). If you want to make changes into the card press this button. It is 
also possible to open a patient’s card by the double click of a mouse at a line in the 
list of patients’ cards of the main window. 
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It is possible to create, open or delete a card also by means of the contextual 
menu, which appears when you press the right button of a mouse on the list of 
patients’ cards (fig. 9). 

 

Fig. 9. 

3.1.5 The Menu of the main window of the program 

It has been already told about some items and commands of the menu above. 
We shall describe the things that have not been mentioned: 

�� The Command “Cardfile -> Open database …” – opens already available 
database; 

�� The Command “Cardfile -> Create database …” –  creates a new database 
(in the new catalogue); 

�� The Command “Cardfile -> New card …” – allows to get a new card for 
the patient; 

�� The Command “Cardfile -> Open card …” – allows to edit a new card for 
the patient; 

�� The Command “Cardfile -> Exit” - exit from the program; 

�� The Command “Cardfile -> Signal import…” – to load previously saved  
signal from the file and attach it to the currently opened patient’s card (the signal 
will appear in the list “Cardiosignals”); 

�� The Command “Edit -> Delete” - to delete a card file, a card, examination 
or the result of examination depending on what list of the main window is active at 
the present moment; 

�� The Command “View -> Refresh” - to refresh a window; 

�� The Command “Setup -> Fields setup…” – to setup the visible fields of 
the “Patients’ cards list”; 

�� The Command “Setup -> Language” - a choice of language of the program 
interface; 



VARICARD-KARDi software. User’s Manual 

16 

�� The Command “Help -> About” - to deduce a window with the 
information about the program. 

3.1.6 Viewing and editing of examination 

In a dialogue window “ECG input” you can view the previous examination 
or to edit it (see item 3.2.1 and 3.2.3). To deduce this window, you should choose 
first a line with the necessary patient in the patients’ cards list. If the chosen patient 
has been examined, then the list “Cardiosignals” will not be empty. Each line in this 
list corresponds to one examination. Choose the necessary examination and press the 

button . 

3.1.7 Viewing results of examination 

You can view the previous results of examination in a dialogue window 
“Results”. To deduce this window, choose first a line with the necessary patient in 
the patients’ cards list. If the chosen patient has been examined and the results have 
been received on the basis of these examinations, the list “Results” will not be 
empty. Each line in this list corresponds to the results of one examination. Choose 
the necessary results (a line in the list) and press the button 

. 

There are some bookmarks in the given window, each refers to a page with 
the corresponding diagram or the textual information. 

The bookmark “IRSA” shows the diagram “Index of regulatory system 
activity” (fig. 10). For evident display the system of type “Traffic light” is used. 
GREEN, YELLOW and RED zones of conditions are provided: which accordingly 
characterize a normal state of the person, prenosological (transient states between 
health and illness) and the prepathological conditions demanding the doctor’s 
attention. The 10-point estimation of conditions is used which for clearness is 
represented as “a ladder of conditions”.   
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Fig. 10. 

The bookmark “Intervals” shows a cardiointervalogram on the basis of 
which the given results of examination are obtained (fig. 11).  

 

Fig. 11. 
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Bookmarks “Histogram”, “Scatergram”, “Autocorrelation” and “Spectrum” 
show accordingly diagrams of the histogram, scatergram, autocorrelation function 
and spectrum (fig. 12-15). 

 

Fig. 12. 

 

Fig. 13. 
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Fig. 14. 

 

Fig. 15. 
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Target documents with all the examination results which are divided into 
three pages are presented on bookmarks “Text 1”, “Text 2” and “Text 3”. The first 
page (“Text 1”, fig. 16) is a graphical information - diagrams which were already 
considered above. The second page (“Text 2”, fig. 17) - text data on basic heart 
rhythm variability parameters: statistical, autocorrelation and spectral analysis. The 
third page (“Text 3”, fig. 18) - the general estimation of heart rhythm system 
regulation status. 
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Fig. 16. 
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Fig. 17. 
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Fig. 18. 



VARICARD-KARDi software. User’s Manual 

24 

The information on any bookmark in this dialogue window can be printed 
out. For this purpose use the menu command of this window “File -> Print…” or 

press the button . In the appeared window “Print document” it is possible to 
choose the printer from the installed in the operational system, to set the size of the 
diagram you want to print and its arrangement on page.  

Diagrams in a window “Results” can be copied also in the operational 
system buffer as a graphic object. For this purpose serves the menu command “Copy 
-> Copy”. 

To leave the dialogue window “Results” and return to the main window of 

the program press the button  or choose the menu command “File -> Exit”. 

 

3.2 “ECG input” window 

3.2.1 The General data 

The given dialogue window is intended for the control of signals input from 
the hardware part of KARDiVAR system, and also for viewing and editing of the 
before entered and saved signals in a database.  

New examination begins by a call of a window “ECG input” with the button 

 in the main window of the program. 

Now we are going to have a look at the general properties. 

The Command “Setup -> Choose scenario…” will show a dialog, where user 
may choose the scenario of patient’s examination. By default the program has two 
scenarios: “Simple examination” , “Ortoprobe” and “Fixed breath”  (fig. 19). 
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Fig. 19. 

The scenario “Simple examination” – intended for signal input for given 
period of time (“Signal input time”) and has the default value 5 min. 

The scenario “Ortoprobe” – intended for signal input divided into three 
stages. Every stage have their own length and name.  

The scenario “Fixed breath” is a scenario which consists of three stages. The 
first stage - free breath. In two others it is necessary to try to coordinate a breath and 
an exhalation of breath with the indicator appearing on the screen. 

Stages goes one by one. The user may view detailed info about every stage 
in scenario by pressing button “Edit current scenario” (fig. 20). 
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Fig. 20. 

In dialog “Investigation stages setup” the button “Add…” will add the new 
stage in the list of the stages of the current scenario. The “Delete” button will delete 
the stage from the list. 

The “Save…” button allow to save in the signle file the all structure of 
scenari (all stages with their properties). The saved file later may be loaded with 
“Load…” button. 

Remark: Three default scenarios (“Simple examination”, “Ortoprobe” and 
“Fixed breath”) have limitations in editing their properties and they cannot be 
deleted. 

Also this dialog have the list of the stages that included in the current 
scenario. In the “Ortoprobe” scenario we see three stages. The every one have their 
own properties. The user may view or change it by selecting item and pressing 
“Change…” button (fig. 21). 
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Fig. 21. 

There are following properties of the stage:  

�� stage name; 

�� stage length; 

�� stage type (if selected “Fixed breath” type the additional window “breath 
indicator” will appear while signal input); 

�� text message that will be showing at sthe starting of the stage (if “Show 
message” is checked); 

�� the permittance to stop signal input at the beginning of every stage (if “Stop 
at the beginning of the stage” is checked) 

The menu command of the menu “Setup -> Options… ” deduces a dialogue 
window “Options”. This window is intended for “ECG input” window work setting. 
The window consists of three sub-windows, chosen by means of three corresponding 
bookmarks: “Main” (fig. 22), “Cardiogram” (fig. 23) and “Intervalogram” (fig. 24). 
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Fig. 22.  

 

Fig. 23. 
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Fig. 24. 

The bookmark “Main” is intended for installation of type of the device (the 
dropping out list “Device type”) and the port of a computer to which the device is 
connected (the dropping out list “Serial port”, to find more about ports setting go to 
the document “KARDiVAR system. User's Guide”). Here it is also possible to 
specify filter options which work during signals input and to choose the channel 
(lead) which will be charged with R-peaks recognition. Later, on the basis of the 
intervalogram received after recognition, the results of examination will be 
calculated. 

The bookmark “Cardiogram” is intended for cardiogram output area 
(drawing area) setting in a window “ECG input”. Here enter:  

�� Group of buttons with independent fixing “Cardiogram window setup” for 
setting of a squared paper display and of some other elements of cardiogram output. 

�� “Additional options” - for installation of sensitivity and speed of input of 
an electrocardiogram by default. During the input these characteristics can be 
changed. 
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�� The Drawn ruler in the bottom part of a window is intended for a squared 
paper calibration which is drawn as a background in the field of ECG drawing of� 
“ECG input” window. Depending on the definition established on the monitor and 
the size of the monitor, the size of a square on a squared paper can mismatch real 
value (1 square = 5 millimeters). To “adjust” the size of a square on a squared paper 
on the screen to the real value, put the real ruler to the drawn one and pressing 

buttons � � combine ruler points. 

The bookmark “Intervalogram” is intended for intervalogram drawing area 
setting in a dialogue box “ECG input”. Here enter:  

�� The Group of buttons with independent fixing “Intervalogram window 
setup”, showing whether to draw or not scales on the intervalogram. 

�� The Line of input “Intervalogram step, pixels” specifies a way of 
intervalogram display, namely distance in screen pixels between vertical «sticks» 
which symbolize distances between R-peaks. 

�� Two input lines on the right set a range on axis Y for the intervalogram 
diagram in milliseconds. 

�� The Button with independent fixing in the bottom part of a window is 
intended to link cursors on the cardiogram- and intervalogram diagram, whereupon 
moving one of them the other one will move after the first one automatically. 

Button “OK” allows to save changes made in a window “Options” if there 
were any. 

3.2.2 Input of a new examination 

After pressing the button  there is a window “ECG input” 
(fig. 25) and the program will try to adjust connection with the hardware. If there are 
any problems the program will inform that the device is not found. In this case check 
up if the device is connected correctly and the drivers are installed (see the 
document “KARDiVAR system. User's Guide”). If everything is all right, then six 
ECG signals on different leads will be displayed at the central part of a window 
“ECG input”. 
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Fig. 25. 

Buttons  are intended for start, stop, 
pause and reset of the input of signals’ process. As the input has already begun, the 
button “Start” is inaccessible, other buttons are accessible. The button “Stop” stops 
the input and a window “ECG input” passes in a mode of viewing and editing of 
examination (see item 3.2.3 and 3.2.4). The button “Pause” temporarily stops input 
of signals. The button “Reset” begins the examination input anew. Pressing this 
button is equal to consecutive pressing of “Stop” and “Start”. The information 
entered in this session before this button has been pressed would be lost. This button 
is used in the following case: after the input beginning we wait while the patient 
takes a comfortable position, we watch the signal quality and then if everything is 
normal we press “Reset”: “The pure” input of inspection has begun. These four 
buttons are duplicated by the corresponding menu commands “Input”. 

By means of dropping out lists  and  it is 
possible to change sensitivity and speed of the input of signals development. 

In the process of input the program recognizes R-Peaks by the channel set in 
options (see item 3.2.1, the menu command “Setup -> Options …” a bookmark 
“Main”) and output R-peaks’ labels above the chosen channel, and also builds a 
cardiointervalogram in the bottom part of a window. Each vertical line on the 
cardiointervalogram corresponds to the time between two R-peaks (current and 
previous). 
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In the information line  the 
number of current interval during the input of signals, last time of input, the value of 
current cardiointerval in milliseconds, and also the heart rate are displayed. 

Last time of input and the number of the entered signals readout are 
displayed in a line of the status in the bottom part of a window. 

On the expiry of time set in options (by default it is 2 minutes) the 
examination input comes to an end and the window “ECG input” passes to a mode 
of viewing and editing of examination (see item 3.2.3 and 3.2.4). 

3.2.3 Viewing of the before saved examination 

In this mode of a window “ECG input” the input of a new examination is 

forbidden and the buttons  are inaccessible 
(fig. 26). This mode is intended for viewing and editing of the before entered 
examination. The examination can be already saved in a database (in this case the 
call of this window is carried out from the main window of the program) or it has 
just finished (the program passes in the mode itself when the time of the input of 
signals is completed or when the button “Stop” is pressed). 

 

Fig.26.  
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It is possible to look signals through by means of a scroll track (it is located 
right under the area of signals’ drawing). It is also possible to move the cursor of a 
mouse to any place of the area of signals’ drawing and, having pressed the left 
button of a mouse without releasing it move the cursor of a mouse to the right or to 
the left (the cursor will change its look). 

In this mode in the area of signals’ drawing there is a marker-cursor (a 
vertical red line) which you can move to the right or to the left on the signals. There 
is a similar marker on the cardiointervalogram . It moves around either by means of 
the keyboard (keys “Left” and “Right”) or by means of the cursor of a mouse (click 
in any place of the drawing area and the marker will move there). In a line of the 
status the information about the time from the beginning of a signal up to the 
position of a marker will change. And also the information about the number (in 
which the marker is) of the current interval and its duration. If we move a marker 
with the double click of a mouse, the interval which is in the marker will be painted 
in yellow color (will be marked) and the similar marker on the cardiointervalogram 
will specify a corresponding interval. As well as in reverse order: if we display the 
marker of the cardiointervalogram with a double click of a mouse then the 
corresponding interval on the signals will be marked with yellow color. These 
markers can be “unlinked” (mutual moving takes place only with the double click of 
a mouse) or “linked” (mutual moving takes place only with the single click of a 
mouse). This function can be initiated or disabled in a window “Options” on a 
bookmark “Intervalogram” (see item 3.2.1). 

The moving of the marker on the cardiosignal can be done in one sample (in 
one millisecond) by means of keyboard keys “Left” and “Right”. It is not very 
convenient, that is why it is possible to use a combination “Ctrl” + “Left” and “Ctrl” 
+ “Right”. The marker moves at once on 500 samples (or on half a second). 

Keys “Left” and “Right” move a marker on the cardiointervalogram on one 
line, that is on one interval. 

3.2.4 Editing of the examination 

To get authentic results, it is necessary that the cardiointervalogram to be 
made correctly. And for this purpose the correct R-peaks recognition is required for 
this purpose. In the input process the program recognizes R-peaks itself, puts R-
peaks’ labels (small triangles above the signal) and makes a cardioinervalogram over 
them. But there are cases when the program cannot recognize correctly some 
cardiosignal fragments. In this case it puts R-peaks’ labels in wrong positions or 
does not put them at all. That is why there is a mode of examination editing in the 
program. It consists in the control over correctness of R-peaks’ labels arrangement 
and the correction of mistakes of their automatic recognition. This mode is 
accessible in a window “ECG input” right after the input of a new examination or at 
opening in this window the examination saved before in a database. 
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When the recognition is correct, R-peak label should point precisely to the 
R-peak top. And only one mark should correspond to each top. 

Here are shown the typical recognition mistakes: 

 

Fig. 27. 

In figure 27 on the first lead near the marker we see the missed R-peak. It 
can happen that there will be even several missed R-peaks successively. Such an 
interval turns out to be longer than usual and is clearly seen on the 
cardiointervalogram. Here it looks like a high line (regarding adjoining ones). It is 
clearly seen in the picture. 
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Fig. 28. 

In figure 28 the incorrectly recognized R-peak is presented (the first lead 
next to the marker): the label points to T-peak instead of R-peak. Such an interval 
would be slightly bigger than usual. If the peak following this one is recognized 
correctly it will be slightly less than usual (due to the previous one). On the 
cardiointervalogram it looks like one line is a little bit higher and then, after it, there 
is a line slightly shorter. It is seen in the picture. 
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Fig. 29. 

In figure 29 we see “unnecessary” R-peak (it has been recognized as a T-
peak). In this case one “correct” interval was broke by this peak into two. There is a 
“hole” in this place on the cardiointervlogram. 

Sometimes one more mistake takes place when two labels stand very much 
close to one another and practically merge in one so that it is not possible to 
understand that there are two labels on the cardiointervalogram. But such a case will 
be very well appreciable on the cardiointervalogram - sharp “hole” or even absence 
of the line which are responsible for an interval.  

Here are the typical recognition mistakes. Each mistake of arrangement of 
R-peaks’ labels can be viewed on the cardiointervalogram. Thus, the control over 
correctness of recognition is reduced to visual viewing of the cardiointervalogram 
and to the search of “problem” places. Further we click two times on the left button 
of a mouse on such a place and we look now at the cardiosignal corresponding to 
this part of the cardiointervalogram. We check the correctness of R-peaks’ lables 
arrangement and edit if it is necessary.  
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Editing is a removal of “unnecessary” R-peaks’ labels and the addition of 
missing ones. To add R-peak label, we place a cardiosignal marker approximately in 
the place where it is necessary to mark R-peak and presses a key “Insert” on the 
keyboard. The program will calculate a maximum of a signal in some area to the left 
and to the right from the marker and put a label in this maximum. The maximum is 
found because as a rule R-peak is a positive splash on the cardiosignal. To insert a 
label precisely in a place of a marker use a combination of keys “Shift” + “Insert”. 
To remove R-peak label, place a mark approximately on the peak the label of which 
you want to remove and press a key “Delete” on the keyboard. The program will 
remove a label nearest to the marker. 

For the search of “problem” places it is possible to use buttons . 
The button “Mn” searches for the smallest interval and places cardiosignal and 
cardiointervalogram markers on it. Button “Mx” searches for the biggest interval 
and also places markers on it. 

Each insert or removal of R-peak marker is displayed on the 
cardiointervalogram at once. 

In the program also there is an opportunity of automatic recognition of R-

peaks after input of a signal in a mode of editing inspections (  button). By 
pressing this button the program will ask to choose the channel on which recognition 
of R-peaks will begin.. Old R-peaks will be lost. In exchange the program will place 
new. It is possible to process all signal or if there is the allocated fragment, only the 
allocated fragment. 

The button  (or menu “ Results-> Recognize arrythmias and artefacts ”) 
allows to carry out automatic search and recognition arrythmias, artefacts and 
unnomotop  intervals. In the appearing dialog (fig. 30) check the items and press " 
Ok ". 

Remark! Before to begin search arrythmias and artefacts recognize R-peaks. 

 

Fig. 30. 
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Recognized arrythmias and artefacts it is possible to cancel by command of 
the menu “ Results-> Undo arrythmias and artefacts ”. 

3.2.5 Cardiointervals’ processing 

When the quality of cardiointervalogram construction is checked and if it is 
necessary, R-peaks’ markers are edited, cardiointervals’ processing follows. Press 

the button  or a the menu command “Results -> Process cardiointervals…”. 
There will be the dialogue window represented in figure 31.  

 

Fig. 31. 

Here in the dropping out list “ Current scenario ” it is necessary to choose 
type of processing of cardiointervals: In case of “ Simple examination ” as initial 
data all signal undertakes. In case of “Ortoprobe” - the program will try to find 
stages in an initial signal and to process data accordingly. 

In block “Cardiointervals” choose what exactly you want to send on 
processing: the whole cardiointervalogram, the selected fragment or only a fragment 
(fragments), marked for processing. If the cardiointervalogram is “good” (all R-
peaks are recognized correctly) then we leave “All”. The mark “Save results in 
database” shows if it is necessary to save the processing results in a database. It 
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concerns only the received results and does not apply to the basic data (signals and 
the cardiointervalogram). If you put this label and press the button “OK” the 
received results will be saved in the database and will become attached to a patient’s 
card, and also will be added to the list “Results” of the main window of the program 
with the corresponding date and time of their organization. If we remove the marker 
and press the button “OK” the results will not be saved in a database and we will be 
able to see them only on the screen in the appeared window “Results”. 

The block “ Errors handling ” allows to check up before processing entrance 
data on errors: arrithmias, artefacts and unnomotop intervals. If to check “ Artefacts 
or “ Unnomotop intervals ”, the program at a finding of these errors will ask what to 
do with such interval: to skip on processing or to remove from processing. If to 
check “Arrythmias”, the program before processing will make additional search of 
arrythmias. 

Further we press the button “OK”, there is a window “Results” with the 
results of processing of examination. This window has been discussed in item 3.1.7. 

After viewing the results (and their printing), we close a window “Results” 
and come back to the window “ECG input”. Further it is possible to return to the 
main window of the program (the menu command “File -> Exit”). The program will 
ask, if it is necessary to save these examinations (cardiosignals, peaks’ markers, a 
cardiointervalogram).We press the button “Yes”. New lines will be added in the lists 
“Cardiosignals” and “Results” in the main window of the program if you saved the 
examination and its results.  

Now it is possible to choose a new patient and start a new examination.  

3.2.6 Additional capacities of the window “ECG input” 

3.2.6.1 Saving of the examination in a file 

The window “ECG input” allows to export the examination (cardiosignal, 
cardiointervalogram and R-peak labels) to a file. If there is an examination opened 
in a window “ECG input”, choose the menu command “File -> Save As…”, enter a 
file name (for example, “name1”) and its location and press “Save”. In the place that 
you specify on the disk some files with the same name (the name specified by you), 
but with different extensions will be created. The group of these files contains all the 
necessary information about one examination: data on the patient, cardiosignals, 
cardiointervalogram, R-peaks’ labels. A file “name1.ixf” – is the “main” file in this 
group, the information on the patient and also the data on what files are included 
into the given examination, are saved in this file. You can send these files in the 
Internet or save on a flash-disk. The main thing is that you should not “destroy” this 
group of files as all these files are important and contain each in itself the 
information on examinations.  
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3.2.6.2 Opening of the examination from a file 

The examination saved before can be opened in a window “ECG input” with 
the menu command “File -> Open…”. Choose the folder Windows and a file with 
extension “.ixf” in the appeared window. The program will load the examination (if 
any of the files lacks in this group, the program won’t be able to open the 
examination) into a window “ECG input” saved in this file (and other files from this 
group). Then it is possible to edit the open examination, process and receive the 
results of this examination.  

3.2.6.3 Export of cardiointervals 

The menu command “File -> Export intervals…” allows to save the 
cardiointervalogram of the open examination in a file. In the appeared window 
“Intervalogram export” (fig. 32) it is necessary to specify what exactly you want to 
export: the whole intervalogram, only the selected fragment  or only a fragment 
(fragments) marked for processing. We choose and press “OK”, further we specify 
the location of the created file, enter its name and press “Save”. The received text 
file (with extension “.txt”) contains cardiointervals of the open examination (each 
interval is saved in a separate line of a file as an integer in milliseconds). 

 

Fig. 32. 
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3.2.6.4 Indication of a fragment on the cardiointervalogram 

It is possible to mark a fragment of cardiointervals on the 
cardiointervalogram. This fragment then may be processed and we receive the 
results of examination according to it or it may be exported to a file. 

To mark a fragment, place a cardiointervlogram marker on the interval that 
will be the beginning of the fragment and press the right button of a mouse. In the 
appeared contextual menu choose the command “Mark fragment beginning”. Then 
move the marker to an interval which will be the end of the fragment and also press 
the right button of a mouse. In the appeared contextual menu choose the command 
“Mark end fragment”. The necessary cardiointervalogram fragment became of light 
yellow color. It is the markeded fragment (see fig. 33). The area corresponding to 
this fragment will be also marked on the cardiosignal automatically. 

 

Fig. 33. 

To remove a fragment indication put the marker inside the marked fragment, 
press the right button of a mouse and in the appeared contextual menu choose the 
command “Hide selection”. The fragment marked this way can be the only one on 
the  cardiointervalogram. 
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3.2.6.5 Indication of a fragment on the cardiointervalogram for processing 

There is another type of fragments’ indication, that is their indication for 
processing. There may be several fragments of this kind. Mark a fragment in a usual 
way. Move a marker inside the fragment. Press the right button of a mouse and in 
the appeared contextual menu choose the command “Mark fragment for processing”. 
The marked fragment will be painted in light green color. Usual indication of this 
fragment will automatically be removed. Then, if it is necessary mark another 
fragment and also mark it for processing (fig. 34). 

 

 

Fig. 34. 

It is possible to process fragments marked this way and to receive the results 
of examinations on them or to export them to a file. Such approach is used for 
processing if the cardiosignal is badly recognized and some of its parts can not be 
recognized. There are “probem” places on the cardiointervalogram too. You can 
choose “good” parts of the cardiointervalogram, indicate them, mark for recognition 
and then process. 

To remove indication of such fragment place the marker of the indicated 
fragment, press the right button of a mouse and in the appeared contextual menu 
choose the command “Unmark fragment marked for processing”. The command 
“Unmark all fragments marked for processing” cancels indication of all the 
fragments of that kind. 
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3.2.6.6 Labels of events 

It is possible to add the so-called labels of events on the 
cardiointervalogram, these are dark blue vertical lines with unique names with the 
help of which it is possible to mark different events. To add a label of event, place a 
marker of the cardiointervalogram on the necessary interval, press the right button of 
a mouse and in the appeared contextual menu choose the command “Insert label…”. 
Then enter the name of the next label and press “OK”. There will be a dark blue line 
on the cardiointrvalogramm with a corresponding name (fig. 35).  

The name of a label of event can be changed - put the marker of the 
cardiointervalogram next to the necessary label, press the right button of a mouse 
and in the appeared contextual menu choose the command “Change label…”, 
change the name and press “OK”. 

To remove a label of event put a marker of the cardiointervalogram next to 
the necessary label, press the right button of a mouse and in the appeared contextual 
menu choose the command “Delete label”. 

 

Fig. 35. 

3.2.6.7 Selection  of the program OutDoc 

The results of examination can be viewed not only by means of a window 
“Results” (item 3.1.7). “OutDoc” is also intended for viewing and printing of the 

results. To select this program press the button . It is accessible after 
examination processing. After this button is pressed there will be a window where it 
is necessary to specify the way to the executable file - “out_doc.exe” (fig. 36). 
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Fig. 36. 

When the button “OK” is pressed the program “OutDoc” starts.  
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3.3 The Program “OutDoc” 

The program of the target document “OutDoc” printing is intended for 
viewing and printing of the results of examination of a patient (The “Passport of 
Health”). The appearance of the main window of the program Out_Doc is presented 
in fig. 37. 

 

Fig. 37. 

It is possible to invoke the program from the program “KARDiVAR” (from 
the main window of the program or from a window “ECG input”), and manually by 
the start of the executed file Out_Doc.exe (it is in the catalogue “C:\Program 
Files\RAMENA\OutDoc” by default). After the program “OutDoc” has been 
invoked, it opens automatically the last (according to the time of creation) file with 
examination results in the catalogue “C:\Program Files \RAMENA\DAT”1. If the 

                                                 
1 This catalogue is intended for files storage with examination results for the 

program “OutDoc” (*.dat-files). The program “OutDoc” searches for the files with 
examination results to open them in this catalogue. It is in “C:\Program Files\RAMENA\DAT” 
by default. It is possible to replace this catalogue with the menu “Options -> Directory…”. It is 
necessary to do the same in the program “KARDiVAR” in order that the catalogue of storage 
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invokation of the program “OutDoc” has been carried out from the program 
“KARDiVAR” then the temporary file is created which is opened. 

There can be opened several files with examination results in the program 
“OutDoc” simultaneously. If you open other examination results from 
“KARDiVAR” program, they open in the already started program “OutDoc”. It is 
possible to open also separate .dat-files with examination results, for this purpose 

press the button  or use the menu command “File -> Open…”. In the appeared 
window (fig. 38) choose a line (or several lines2) and press the button “Open”. The 
files that you have chosen will open. If you want to view the list of files already 
opened in the program “OutDoc”, and also choose one of them, go to the menu 
“Patient”. The current file is marked with a point. If you want to close any file from 
the list of opened files use  the menu command “File -> Close”. The command “File 
-> Close all” closes all the open files. 

 

Fig. 38. 

The button  is intended for copying the window content of the program 
“OutDoc” in the clipboard Windows as an image. The dropping out list 

 serves for image scale management. 

                                                                                                        
of *.dat-files’ in the program “KARDiVAR” coincided with the catalogue of opening of these 
files of  “OutDoc” program. 

2 For this purpose press Ctrl on the keyboard and without releasing it in the list 
mark the lines that you are interested in with the left button of a mouse. To remove the marker 
from the line click the mouse again, release Ctrl and then click anywhere.  
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By default the text conclusion may be chosen from the menu “Options -> 
“Conclusion current setup …”. It is unique for each IRSA value. Thus you can adapt 
the conclusion for concrete IRSA value. Entered by you changes will be saved. 
Besides, there is an opportunity to correct the conclusion for each patient 

individually. For this purpose use the button  or a the menu command “Options -
> Conclusion current setup…”. Here it is necessary to pay your attention that after 
you have closed a current file or when you quit the program “OutDoc”, your 
changes in the current conclusion will be lost. 

For printing press the button  or choose the menu command “File -> 
Print”. In the appeared window (fig. 39) it is necessary to choose the printer from the 
installed ones in the operational system (the button “Printer setup”). And also to 
choose the mode of color rendering: colored or black-and-white, and the mode of 
data print: “Document” (The “Passport of Health” is printed in the form in which it 
is represented in the program), “Blank” (the information that is general for all the 
patients is printed) and “On blank” (the information unique for each concrete patient 
is printed). Modes “Blank” and “On blank” print the information that is mutually 
complementary. The surnames of patients whose results are opened at the present 
moment in the program are enumerated in the list. You tick off surnames The 
“Passports of Health” of which you want to print. 

 

Fig. 39. 



VARICARD-KARDi software. User’s Manual 

48 

3.4 The program “Dinakont” for show and print of di agram of 
examination results over a period of time 

The program “Dinakont” allows to view and if it is necessary to print 
diagrams of examination results of the current patient. The initial data for this 
program is the list of results displayed in the dialog window “ Results list” (fig. 40). 

This window appears if to press the button  in the main 
window of the program KARDiVAR: “KARDiVAR Registry”. 

 

Fig. 40. 

This list duplicates the list “Results” in the main window. Choose necessary 
lines in a window “ Results list ” (by "clicking" check boxes in the items) to send 
corresponding results to the program “Dinakont”. Then press button "Ok". The 
results will be written in a temporary file with extension “.din” which will be 
automatically open in the program “Dinakont”. Appearance of the program 
“Dinakont” is shown on fig. 41. 
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Fig. 41. 

The results are presented in the form of the table both in the form of 
diagrams. And in the table and on diagrams can be displayed no more 10 
parameters. Which parameters from results will be displayed the user can select in 
corresponding windows of the program “Dinakont”. Commands of the menu are 
intended for this purpose: “ Options-> List of parameters for table … ” and “ 
Options-> List of parameters for diagrams … ”. The view of this window is 
presented on fig. 42.  
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Fig. 42. 

In the right list there are parameters which can be included or "switched off" 
for display in columns of the table (or on diagrams). In the left list results which also 
can be included or "switched off" for display in lines of the table (on diagrams they 
are presented by separate points). 

The button  allows to copy any diagram into the Windows’ clipboard. 
Which diagram to copy – may be chosen from the dropping menu. The table with 
parameters can be exported to a text file with separators or copy into Windows’ 
clipboard as the text. For this purpose execute a command of the menu “ File-> 
Export of the table … ”. 

In the program “Dinakont” there can be open simultaneously some files with 
results of examinations of several patients. If you wish to open previously saved 

“.din” file with results of examinations for this purpose press the button  or use a 
command of the menu “ File-> Open … ”. The appeared window is similar to a  
open dialog  of the program “OutDoc” .  

Working with the program “Dinakont” in many respects is similar to work 
with the program “OutDoc” (see item 3.3). 
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4. Algorithm of work with KARDiVAR system 

Step 1: Preparation 

Connect the electronic key to USB port. 

Connect the ECG-amplifier to USB port (more detail see “KARDiVAR-
User's Guide”). 

Start the program “KARDiVAR”. 

Open the necessary database. Choose item of the menu “Cardfile -> Open 
database…”. Click on a folder that you are interested in and press the button “OK”. 
Or create new databases through the menu “Cardfile -> Create database…”. 

Select CardFile list and if it is necessary create a patient’s card (more detail 
see items 3.1.2 and 3.1.4). 

Step 2: Preparation of the patient 

Fix the electrodes under the standard scheme of assignments, preliminary 
having greased points of imposing by gel: a red electrode (R) on the right hand, a 
yellow electrode (L) on the left hand, a green electrode (F) on shin of the left leg, a 
black electrode (N) on a shin of the right leg . If application of gel for any reasons is 
undesirable, it can be limited to wetting the point of contact by water. Be convinced, 
that electrodes are fixed without a mistake on the specified color conformity. At a 
weak signal it is desirable to degrease preliminary by skin mix (spirit and ether in 
the ratio 1:1). Pay special attention on quality of contact of electrode N on which 
quality of an electrocardiogram in other channels R, L, F depends.  

 
Diagram of applying electrodes. 
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Step 3: ECG Signal Acquisition  

To begin the examination press the button  in the main 
window of the program and pass to a dialogue window “ECG input”. If the amplifier 
is connected correctly then on the screen there will be an ECG-signal. If you need to 
change parameters acquisition of a signal then to press the button  “Stop” and setup 
of ECG-signal acquisition parameters in the menu “Setup” (more detail see item  
3.2.2). 

Next press the button “Start” for acquisition signal. 

During acquisition of a signal supervise a condition of the patient and quality 
of a acquisition signal. 

Step 4: Preparation to Analysis 

After acquisition of a signal make necessary corrections in recognition of R-

peak. For this purpose press the button , or choose a suspicious interval on the 
cardiogram and edit it manually. 

If it is necessary then mark the intervals which will be analyzed.  

Step 5: Analysis 

If the cardiogram is correct it is possible to pass to its analysis. Press the 

button  . 

Be convinced that the analysis has passed correctly, else repeat steps 4, 5. 

Save or print the received results. 
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Appendix A: Structure of a database 

The database consists of several tables in Paradox 7.0 format - the basic data 
table (it contains patients’ published data), the database of results (it contains results 
of  patients’ examinations), a database for cardiogram and cardiointerval storage and 
also several auxiliary tables. Structures of these tables are given in tables 1, 2, 3 and 
4. 

Table 1 
Registry.db - the table with registration data, it contains patients’ published data 

�  Field name Field type Key Description 
1 NUMBER A8 * Number of patient’s history 
2 FILE_ID S * Card file number 
3 COMEDATE @  Date and time of receipt 
4 NAME A60  Surname, name, patronymic 
5 SEX A1  Sex 
6 BIRTHDAY @  Date of birth 
7 BIRTHYEAR S  Year of birth (if the date of birth is 

not set) 
8 HEIGHT N  Height 
9 WEIGHT N  Weight 
10 COUNTRY A25  Country 
11 PARTS A25  Part 
12 ZONE A25  Zone 
13 REGION A25  Region 
14 CITY A25  City 
15 STREET A25  Street 
16 HOUSE A25  House 
17 FLAT A25  Apartment 
18 ENTERPRISE A25  Enterprise 
19 DEPARTMENT A25  Department 
20 SECTOR A25  Sector 
21 TITLE A25  Post 
22 ATTEND S   
23 REM A100  Notes 
24 CHARSET S  The code table of the given card 
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Table 2a 
File_id.db – the table of card file names, auxiliary for the basic table 

�  Field name Field type Key Description 
1 FILE_ID S * Card file number 

2 FILE_NAME A50  Card file name 

 
Table 2b 

History.db – the table of history of data input about place of residence, place of 
work, auxiliary for the basic table 

�  Field name Field type Key Description 
1 WHAT S   

2 ITEM A25   

 
Table 2c 

MoreInfo.db - the table of the additional information on the patient, auxiliary for the 
basic table 

�  Field name Field type Key Description 
1 NUMBER A8 * Number of patient’s history 

2 FILE_ID S * Card file number 

3 INFO M3  Memo 

 
 

Table 3a 
Results.db – the table of examination results, it contains the results on patients’ 

examinations 
�  Field name Field type Key Description 
1 NUMBER A8 * Number of 

patient’s history 
2 FILE_ID S * Card file number 
3 GROUP_ID I * Number of a 

group of the 
initial signal 

4 SIG_TYPE S * Initial signal type 

The index 
on the initial 
signal for 
this 
examination 
result  

5 RES_GROUP A16 * Group of examinations 
6 AUTO + * Autoincrement field 
7 DATETIME @  Date and time of examination 
8 RESULTS M3  Memo-field with the results 
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Table 3b 
The description of a field in format RESULTS of the table Results.db 
Example Description 

[Results] Name of the section 
Count=1 Number of examinations 
Number=1 Number of patient’s history 
Name=aaa First name, middle name, last name 
Date=01.02.2000 Date of examination 
Time=20:14:14 Time of examination 
Age=26 Age 
Sex=0 Sex 
[1] Section with the results of the first examination 
StateStr=lie Functional state 
FragTime=00:05:00 Length of the processed intervalogram fragment  
RMSSD=0.014574  
pNN50=0.000000  
ArCount=0.000000  
xmax=1.055000  
xmin=0.940000  
MxDMn=0.115000  
MxRMn=1.122340  
Moda=0.999000  
ModaAmpl=94.135840  
INRS=409.696000  
Mean=1.000009  
CHSS=59.999460  
Disp=0.000502  
SKO=0.022416  
CV=2.241611  
VR=0.000000  
rr1=0.779490  
ANStep=13  
StatProcess=1 Process stationarity 
PARS=3 PARS 
P1=0 PARS -1 
P2=1 PARS -2 
P3=2 PARS -3 
P4=0 PARS -4 
P5=0 PARS -5 
Intervals=301 Number of cardiointervals 
Int1=1.100000 First cardiointerval 
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Continuation of table 3b 
…  
Int301=1.030000 Last cardiointerval 
HistogCount=40 Number of histogram values 
His1=0 First value 
…  
His40=0 Last value 
CorrelCount=129 Number of values of autocorrelation function 
Cor0=1.000 First value 
…  
Cor129=0.098 Last value 
SpecMCount=40 Number of values of spectral analysis results  
SpecM1=59.999458  
SpecM2=22.416315  
SpecM3=502.491150  
SpecM4=3.840541  
SpecM5=1039.367188  
SpecM6=11.083333  
SpecM7=2.241611  
SpecM8=150.711365  
SpecM9=1.158762  
SpecM10=35.377354  
SpecM11=0.054465  
SpecM12=0.000000  
SpecM13=2.696528  
SpecM14=85.333336  
SpecM15=4.189589  
SpecM16=0.104375  
SpecM17=0.153325  
SpecM18=0.185944  
SpecM19=23.526798  
SpecM20=34.560410  
SpecM21=41.912792  
SpecM22=2.283069  
SpecM23=2.296384  
SpecM24=2.552966  
SpecM25=0.498109  
SpecM26=5.120039  
SpecM27=3.250472  
SpecM28=5.988304  
SpecM29=15.058824  
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Continuation of table 3b 
SpecM30=30.117647  
SpecM31=0.290739  
SpecM32=1.488595  
SpecM33=5.165103  
SpecM34=0.000977  
SpecM35=0.000000  
SpecM36=0.000000  
SpecM37=0.000000  
SpecM38=0.000000  
SpecM39=0.000000  
SpecM40=0.000000  
SpecLen=2048 General number of values of spectral function 
OldSpecLen=1024 Number of values at input 
SpecS0=0.000001 First value 
…  
SpecS2048=0.000001 Last value 
iHFl=512 Borders of spectrum ranges 
iHFr=154 Borders of spectrum ranges 
iMFl=154 Borders of spectrum ranges 
iMFr=51 Borders of spectrum ranges 
iLFl=51 Borders of spectrum ranges 
iLFr=15 Borders of spectrum ranges 
ExceptCount=0  

 

Table 4a 
Signals.db – the table of initial signals 

�  Field name Field type Key Description 
1 NUMBER A8 * Number of patient’s history 

2 FILE_ID S * Card file number 

3 GROUP_ID I * Number of a group where this signal 
belongs (channels of one signal have 
equal GROUP_ID) 

4 SIG_TYPE S * Signal type 

5 SIG_ID A8 * Control sumCRC-32 

6 DATETIME @  Date and time of a pickup 

7 SIGNAL B  Signal data 

8 SIG_ADD M3  Additional data on signal 
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Table 4b 
The description of a field in format SIG_ADD of the table Signals.db 

Example Description 
[Settings] Section name 
Source=ISCIM6  
DataID=1 Signal type (I lead) 
Device=7 Device type 
DrawLead=000000000000000000000000
00111001 

Template of the taken signals 

Sense=10 Sensitivity 
Compression=1 0 – without compression, 1 -  with 

compression 
Size=00:03:55 Time of pickup 
Freq=300 Frequency of digitization 
Bits=8 ADC capacity 
Align=2 Number of bites on readout 
OriginalSize=141440 Size of the original file 
CompressedSize=52436 Size of the compressed file 
Comments=aaa Comments 
SD=120 Systolic pressure 
DD=80 Diastolic pressure 
 

 

 


